[ECOS] debugging with gdb

Will Wagner will_wagner@carallon.com
Fri Nov 12 11:49:00 GMT 2004


Can you give me more information on what configuration options I need to 
set.

I have tried to build my application so that its address is set at 
compile time and is different from the one redboot uses. However this 
doesn't work. What gdb stubs options must I build the application woth?

Many thanks,

Will Wagner

Andrew Lunn wrote:
> On Thu, Nov 11, 2004 at 05:27:46PM +0000, Will Wagner wrote:
> 
>>I have an A&MViper powerpc860 board up and running. I am currently 
>>investigating debugging options. The board has redboot on it with gdb stubs.
>>
>>If I configure ecos not to have a network stack then I can connect to 
>>the board with gdb over the network and download, run and debug my test 
>>app. If I build ecos with network support it doesn't work as when the 
>>code is run it initialises the network which obviously resets the 
>>connection to gdb.
>>
>>Is there a way to prevent this from happening? I assume not. I could 
>>presumably do the same but use the serial port although I don't want to 
>>do it as it will be slow and I need the serial port for other things.
> 
> 
> This does work, you can share the ethernet device between the
> application and the stub. You just have to ensure there are two
> different IP addresses.
> 
>         Andrew


-- 
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list