[ECOS] Re: Uploading and saving images

Wayne Gemmell wayneg@ananzi.co.za
Tue Nov 9 20:38:00 GMT 2004


On Tuesday 09 November 2004 16:31, Gary Thomas wrote:
> note: this is not an eCos development issue - it belongs on the
> eCos discussion list.
Sorry *blush* I'm not even subscribed to that list.
>
> On Tue, 2004-11-09 at 08:23, Wayne Gemmell wrote:
> > Hi all,
> >
> > I hope you guys can shed some light on this problem for me.
> >
> > When I try upload files through Minicom using X or Y Modem
> > protocols I get lots of NAK errors and then
> >
> > Ymodem sectors/kbytes sent: 249/31kRetry 0: NAK on sector
> > Ymodem sectors/kbytes sent: 253/31kRetry 0: NAK on sector
> > Ymodem sectors/kbytes sent: 254/31kRetry 0: Cancelled
> >
> > Transfer incomplete
> >
> > RedBoot> load -m y
> > *** Warning! Checksum failure - Addr: 207990, FF <> 46
> > xyzModem - CRC mode, 253(SOH)/0(STX)/2(CAN) packets, 123 retries
> > RedBoot>
> >
> > I get the same results from xmodem.
> >
> > My transfer protocol settings are
> > B  ymodem     /usr/bin/sb -vv                 Y    U    N       Y       Y
> > C  xmodem     /usr/bin/sx -vv                 Y    U    N       Y       N
> >
> > I can however load up the program in hyperterminal in Windows. I've been
> > messing around for a while now with no luck.
>

> What target/platform?
This is from the Redboot startup
"Platform: FAL (V850/SA1)"
Its for the f35xxlsi unit.
> What speed is the connection?
38400
> Can you download smaller files?
No, I tried a tiny file with the same effects.

> Are you sure that your timing is setup up properly?  The RedBoot load
> command should issue a 'C' about every 3-5 seconds if you don't send
> anything.
I have no idea how to set this. I've ordered the book online and I've got to 
wait too long still for delivery.

Regards
Wayne


-- 
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list