[ECOS] JFFS2 write trouble

Joshua Boyd jdboyd@jdboyd.net
Wed Mar 31 21:05:00 GMT 2004


On Tue, Mar 30, 2004 at 11:08:30PM +0200, Andrew Lunn wrote:
> > I'm not sure what other information would be pertinent, so please ask.
> > I really need help.
> 
> Where is your redboot? Also in flash? 
> 
> The problem could be that while the write is going on, something is
> calling into redboot. But redboot is not accessible since the flash is
> in write mode. Hence the crash.
> 
> Try a ROMRAM redboot, so that it loads itself from Flash into ram and
> then runs.

Closer investigation spurred by your comments revealed that ECOS was in
fact using the flash. Putting a scope on the flash CE_N line showed it
was blinking constantly. 

We don't have time to do a RedBoot ROMRAM version.  However, by playing
with the virtual vectors settings for ECOS, and the debugging options,
and some other options, we have managed to build an ecos that can be
boot strapped from the RedBoot ROM, but then proceeds to access the
flash chip only when we want it to.

I don't have time at the minute to list everything I changed.  I believe
the key ones were:
CYGSEM_HAL_USE_ROM_MONITOR == 0
CYGDBG_HAL_DEBUG_GDB_INCLUDE_STUBS == 1
CYGDBG_KERNEL_DEBUG_GDB_THREAD_SUPPORT == 0
and especially
CYGSEM_HAL_VIRTUAL_VECTOR_INIT_WHOLE_TABLE to TRUE

After that I think it was mostly hunt the dependencies.  I can answer
specific questions people may have.  I just wanted to send a summary for
the archives.

-- 
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list