[ECOS] re: pthreads on i686 pc.

Jason Thomas jason@cosmic.utah.edu
Sun Mar 21 03:27:00 GMT 2004

    Thanks for both of your help with the pthreads problem. Both setting
the attributes from cyg_user_start and using "main" worked. Why is it
that there are differing starting points like this? I'm also still
having some strange problems with the threads, now the thread gets
executed, but upon exiting my program crashes with this message:

Program received signal SIGILL, Illegal instruction.
[Switching to Thread 5]
0x22000000 in ?? ()

    Some how the thread is executing code at a some random position, I
think since the function doesn't have a valid return address, the
"ret" instruction at the end of my function is returning to whatever
exists on the stack at the positon of the return address. I tried
using "pthread_exit", but it doesn't seem to do anything. Also, does
any one have any clue why gdb isn't loading a symbol table for my

-Jason Thomas.

Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss

More information about the Ecos-discuss mailing list