[ECOS] Re: eCos: FAT file system and device driver

Savin Zlobec savin@elatec.si
Wed Mar 10 13:04:00 GMT 2004

Henrik Mau wrote:

> Dear Mr. Zlobec,
> I am a student at SLI-Institute in Livingston, Scotland currently 
> working on my Masters dissetation.
> I am to write a device driver for a piece of HW plugged into an Arm 
> Integrator running eCos. The piece of HW is a storage device using the 
> FAT File System and I had planned to take advantage of the FAT FS 
> developed by Elatec.
> I encounter a few problems when I run the test application provided to 
> exercise the FAT FS.
> The FAT fails to mount and I have traced it down to the device not 
> being present in the device table.
> I have tried using the two ecm files (fat16 and fatfd) to make a build 
> of eCos, but I get the same result.
> As I am new to eCos and have difficulties finding documentation on it 
> I was hoping you could provide me with some insight into what I am 
> doing wrong.

Use 'fat16.ecm' and 'fatfd.ecm' in synthetic target configurations. 
'fat16.ecm' is meant to be used with disk image containing fat fs - the 
describes how to create one. 'fatfd.ecm' is for accessing floppy disk on 
host PC, since floppy disks don't support partitions you need to use the
'/dev/disk0/0' device when mounting the fs - device naming is also 
described in README.txt.

In case you already did all this, then try enabling the debug info in 
'io/disk/disk.c' it should give you a better idea what is going wrong.


Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss

More information about the Ecos-discuss mailing list