[ECOS] bzImage support for i386 targets

Jonathan Larmour jifl@eCosCentric.com
Wed Mar 3 20:57:00 GMT 2004


Narendra Hadke wrote:
> Hi,
>     I am working on porting  redboot to i386 architecture board with
>  AMD SC520. I got the code from CVS Feb 13 and applied patch
>  for bzImage support from Masato Tarunishi which is available
>  on net. With this patch I am able to download "bzImage" from
>  local disk as well as network using tftp.
>   I used following commands:
>   RedBoot> load -m disk hda2:/boot/bzImage ( from local disk )
>   Redboot> load bzImage   ( from network )
>   Both the commands return same size.
>     The box is able to boot with bzImage downloaded from local
>  disk with "exec" command but with network downloaded "bzImage"
>  it just struck( hangs ). Both the images are same.

I'm not familiar with that patch, but bzImages don't contain address 
information so won't you have to load them at a specific address, and then 
use exec with -b ? But don't take my word for it as I haven't looked at the 
patch.

>  the exec command I am using is 
>   RedBoot> exec -c "console=ttyS0,19200 rw root=/dev/hda2"
>  Any pointers what may be wrong? Please let me know if you need
>  any other info.

Have you checked using tcpdump if the file is being transferred?

Jifl
-- 
eCosCentric    http://www.eCosCentric.com/    The eCos and RedBoot experts
 >>>>> Visit us in booth 2527 at the Embedded Systems Conference 2004 <<<<<
March 30 - April 1, San Francisco http://www.esconline.com/electronicaUSA/
--["No sense being pessimistic, it wouldn't work anyway"]-- Opinions==mine


-- 
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list