[ECOS] problem using SMC1 serial port of A&M Rattler as console

agyhoo agyhoo@yahoo.com
Tue Jan 20 21:48:00 GMT 2004


Got it. Thanks a bunch for your help.

- A
--- Gary Thomas <gary@mlbassoc.com> wrote:
> On Tue, 2004-01-20 at 14:20, agyhoo wrote:
> > I am pretty sure my Redboot version is older than the
> 12/16
> > change you made. I did try checking out the eCos
> sources
> > prior to the 12/16/03 change you mentioned. When I
> build
> > and execute now, the serial port works. I do get some
> > garbled text initially but then the console I/O seems
> to
> > work fine.
> > 
> > So, in order to use the latest code, I need to build
> > redboot from the latest sources, then ? Did your change
> > affect redboot as well?
> 
> The change I made affects the diagnostic serial I/O
> routines.
> Normally, applications use the version of this code which
> is
> in RedBoot (via the virtual vector table), so to benefit
> from
> this change, you'll need to update RedBoot.
> 
> > 
> > _A
> > 
> > PS. Sorry for the repeat post..I forgot to CC the list
> the
> > last time.
> 
> Glad to see you're thinking of everyone :-)
> 
> -- 
> Gary Thomas <gary@mlbassoc.com>
> MLB Associates
> 


__________________________________
Do you Yahoo!?
Yahoo! Hotjobs: Enter the "Signing Bonus" Sweepstakes
http://hotjobs.sweepstakes.yahoo.com/signingbonus

-- 
Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
and search the list archive: http://sources.redhat.com/ml/ecos-discuss



More information about the Ecos-discuss mailing list