[ECOS] Need help building RedBoot for Xilinx ML300 board

Bart Veer bartv@ecoscentric.com
Wed Jan 14 18:41:00 GMT 2004


>>>>> "Mike" == Mike Wellington <wellington@lucent.com> writes:

    Mike> I am trying to build redboot for the ml300 board, but I'm
    Mike> having trouble because I'm not familiar with the
    Mike> ecos/redboot build/configuration process.

    Mike> I did the following commands (from page 75 of the eCos
    Mike> reference manual) :

    Mike> I'm not sure if "xilinx_ml300" is the right alias to use
    Mike> here:

    Mike> <----- to create the build tree ------->
    Mike> [be@pcmw ml300]$ ecosconfig new xilinx_ml300 redboot
    Mike> ecos.db, package CYGPKG_HAL_M68K_MCF52xx_MCF5272_MCF5272C3: warning
    Mike>      Version subdirectory `current' does not have a CDL script
    Mike> `hal_m68k_mcf52xx_mcf5272_mcf5272c3.cdl'.
    Mike> ecos.db, package CYGPKG_HAL_M68K_MCF52xx_MCF5272_MCF5272C3: warning
    Mike>      This package does not have any valid version subdirectories.
    Mike> <----end of output from attempt to build the build tree --------->

    Mike> Then I try to import the appropriate platform RedBoot
    Mike> configuration file, here for RAM configuration:

    Mike> <---- output of attempt to import the configuration file ------->
    Mike> [be@pcmw ml300]$ ecosconfig import   \
    Mike> /mnt/hda7/mind/Virtex2Pro/src/ecos/packages/hal/powerpc/ml300/current/misc/redboot_RAM.ecm
    Mike> ecos.db, package CYGPKG_HAL_M68K_MCF52xx_MCF5272_MCF5272C3: warning
    Mike>      Version subdirectory `current' does not have a CDL script
    Mike> `hal_m68k_mcf52xx_mcf5272_mcf5272c3.cdl'.
    Mike> ecos.db, package CYGPKG_HAL_M68K_MCF52xx_MCF5272_MCF5272C3: warning
    Mike>      This package does not have any valid version subdirectories.
    Mike> /mnt/hda7/mind/Virtex2Pro/src/ecos/packages/hal/powerpc/ml300/current/misc/redboot_RAM.ecm: 
    Mike> error
    Mike>      The savefile contains a cdl_option for an unknown option
    Mike> `CYGHWR_DEVS_FLASH_AMD_TH50VSF258'
    Mike> Invalid savefile
    Mike> "/mnt/hda7/mind/Virtex2Pro/src/ecos/packages/hal/powerpc/ml300/current/misc/redboot_RAM.ecm".
    Mike> 1 error occurred while reading in the savefile data.
    Mike> <---- end of output of attempt to import the configuration file --->

    Mike> Can anybody please explain to me what is wrong and how to
    Mike> fix it?

The ml300 support has not been contributed to the public eCos source
tree, so I do not know who did the work or exactly what is in the
release you have been given. Certainly it looks like whoever made this
release skimped on the releng QA: the sources you have been supplied
do not match the RedBoot build.

First, these messages:
    ecos.db, package CYGPKG_HAL_M68K_MCF52xx_MCF5272_MCF5272C3: warning
          Version subdirectory `current' does not have a CDL script
    `hal_m68k_mcf52xx_mcf5272_mcf5272c3.cdl'.
    ecos.db, package CYGPKG_HAL_M68K_MCF52xx_MCF5272_MCF5272C3: warning
          This package does not have any valid version subdirectories.

These are just warnings so you can ignore them, but it may be possible
to fix them fairly easily. Look for a directory
packages/hal/m68k/mcf52xx/mcf5272/mcf5272c3/plf/current. This should
contain a file hal_m68k_mcf52xx_mcf5272_mcf5272c3.cdl. If there is a
.cdl file there with a different name, just rename it. Otherwise
create an empty file with that name - the contents do not matter
unless you try to build eCos for that target.

It looks like you have correctly figured out the basic process for
rebuilding RedBoot:

  $ ecosconfig new <target> redboot
  $ ecosconfig import <.ecm file>
  $ ecosconfig tree
  $ make

xilinx_ml300 would seem to be a valid target in the release you have
been given. ml300 might work as well, usually one or more aliases are
provided for any given target.

Now for the real problem:

    The savefile contains a cdl_option for an unknown option
     `CYGHWR_DEVS_FLASH_AMD_TH50VSF258'
    Invalid savefile
    "/mnt/hda7/mind/Virtex2Pro/src/ecos/packages/hal/powerpc/ml300/current/misc/redboot_RAM.ecm".

Presumably the xilinx_ml300 board uses a th50vsf258 flash chip. I
don't have any information on this part, but I guess it is just
another AMD-compatible flash chip. Whoever did the xilink_ml300 port
added support for this chip to the AMD flash device driver package in
packages/devs/flash/amd/am29xxxxx/current, but then shipped an older
version of the driver. That makes it impossible to rebuild RedBoot. I
suggest contacting whoever provided the release and asking for the
right version of the driver.

Bart

-- 
Bart Veer                       eCos Configuration Architect
http://www.ecoscentric.com/     The eCos and RedBoot experts

-- 
Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
and search the list archive: http://sources.redhat.com/ml/ecos-discuss



More information about the Ecos-discuss mailing list