[ECOS] gdb:stepi/continue problem

Ganeshan ganeshan@ads-networks.com
Wed Jan 14 06:04:00 GMT 2004


Hi
I am herein enclosing the still a finer details of gdb

$ h8300-elf-gdb -nw a.out
GNU gdb 6.0
Copyright 2003 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you
are
welcome to change it and/or distribute copies of it under certain
conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.

This GDB was configured as "--host=i686-pc-linux-gnu --target=h8300-elf"...

(gdb) set remotebaud 38400
(gdb) target remote /dev/ttyS0
Remote debugging using /dev/ttyS0
0x000060f2 in ?? ()
(gdb) load
Loading section .text, size 0x1506e lma 0x204000
Loading section .rodata, size 0x7a4 lma 0x21906e
Loading section .data, size 0x64c lma 0x219814
Loading section .int_hook_table, size 0x100 lma 0x219e60
Start address 0x204000, load size 89950
Transfer rate: 17133 bits/sec, 63 bytes/write.
(gdb) set debug remote 1
(gdb) si
Sending packet: $Hc0#db...Ack
Packet received: OK
Sending packet: $s#73...Ack

*************************************************************
2. continue
(gdb) c
Continuing.
Sending packet: $Z0,204214,2#41...Ack
Packet received:
Packet Z0 (software-breakpoint) is NOT supported
Sending packet: $m204214,2#f8...Ack
Packet received: 7902
Sending packet: $X204214,2:W0#a4...Ack
Packet received: OK
Sending packet: $Hc0#db...Ack
Packet received: OK
Sending packet: $c#63...Ack





Yoshinori Sato wrote:

> At Tue, 06 Jan 2004 13:06:45 +0530,
> Ganeshan wrote:
> >
> > I'm running ecos on a hitachi h8300h 3064 board.
> > I boot up to redboot and connect to the serial port via
> > Gdb and load my ecos application image.
> >
> > I could not able to stepi or continue after loading the image.
> > $ h8300-elf-gdb -nw a.out
> > (gdb) set remotebaud 38400
> > (gdb) target remote /dev/ttyS0
> > Remote debugging using /dev/ttyS0
> > 0x000060f2 in ?? ()
> > (gdb) load
> > Loading section .text, size 0xfbaa lma 0x204000
> > Loading section .rodata, size 0x985 lma 0x213baa
> > Loading section .data, size 0x6e0 lma 0x214530
> > Loading section .int_hook_table, size 0x100 lma 0x214c10
> > Start address 0x204000, load size 68879
> > Transfer rate: 17219 bits/sec, 63 bytes/write.
> > (gdb) stepi
> >
> >
> > Nothing is displayed.  It is same for "continue" also.  What might be
> > the problem?
> >
> > Thanks in advance
> >
> > Ganeshan N
>
> There is the problem that some instruction cannot trace normally.
> It is signed off, but cannot prepare a patch.
>
> --
> Yoshinori Sato
> <ysato@users.sourceforge.jp>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: ganeshan.vcf
Type: text/x-vcard
Size: 349 bytes
Desc: Card for Ganeshan
URL: <http://sourceware.org/pipermail/ecos-discuss/attachments/20040114/e7a4c8aa/attachment.vcf>
-------------- next part --------------
-- 
Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
and search the list archive: http://sources.redhat.com/ml/ecos-discuss


More information about the Ecos-discuss mailing list