[ECOS] Re: configure configuretool error

sandeep shimple0@yahoo.com
Thu Dec 30 13:38:00 GMT 2004


twomol wrote:
>   Happy new year!
same to you. wish that new year brings you visions that help you overcome the
problems you are facing. :)

>   Yes,It outputs "sh is /bin/sh" .I'm a newbie.I don't know why the
configurescript can't find the sh.Any ideas?

- put "set -x" at the beginning of your misbehaving script, so that it looks
something like ....
------------------
#! /bin/sh
set -x
....
------------------

this will help you track down the point where things are going wrong in script.
it could be things like tcl shell is not found or some other problem. sometimes
spewed out error messages can be misleading.

hope, following sample session gives you some clue in going about debugging your
problem.

[/tmp]ls -l x.sh
-rwxr-xr-x  1 sandeep users 48 Dec 30 19:20 x.sh
[/tmp]cat x.sh
#!bin/sh
set -x
echo hi
missingcommand
echo bye
[/tmp]sh x.sh
+ echo hi
hi
+ missingcommand
x.sh: line 4: missingcommand: command not found
+ echo bye
bye
[/tmp]./x.sh
-bash: ./x.sh: bin/sh: bad interpreter: No such file or directory


--
regards
sandeep
--------------------------------------------------------------------------
visit me at http://members.fortunecity.com/sandeepkumar/

Boston, n.:
	Ludwig van Beethoven being jeered by 50,000 sports fans for
finishing second in the Irish jig competition.
--------------------------------------------------------------------------


-- 
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list