[ECOS] Trying to recompile redboot...

John Dowd jdowd@precidia.com
Tue Dec 14 16:52:00 GMT 2004


Am I correct in assuming that this is a "purchased" product (GnuPro?)?

On Tuesday 14 December 2004 11:47, Jerzy Dyrda wrote:
> Hello John,
>
> I use xscale-elf from Red-Hat-3.3 20021213 and npe v.1.4 with success.
> When I was using arm-linux-gcc than  I had always  compiler errors -
> wrong asm. instruction or something like this.
>
> Best Regards
> jerzy
>
> John Dowd wrote:
> >I'm trying to create my own image of the redboot RAM image for a Coyote
> > (GRG) board.
> >
> >My toolset is:
> >arm-linux-tools-20031127
> >redboot-intel-xscale-030630
> >npe version 1.4
> >
> >Has anyone been able to use the toolset listed here? It just seems that
> > the ecos system by defaults to xscale-arm toolset. Right now I'm getting
> > compile errors which occured after I added the npe support.
> >
> >Prior to adding the npe support I was able to compile but I was getting a
> > RAM image that was padded with about 0x20000 zero bytes at the beginning
> > of the image. This of course meant that the image would not load.
> >
> >Any advice would be appreciated.
> >
> >             Cheers!!

-- 
-----------------------------------------------------------------------------
  "No matter where you go, there you are."
                          Buckaroo Banzai

                                        John Dowd
                                        Software Designer
                                        Precidia Tech.
                                        jdowd@precidia.com
                                        (613)592-7557 ext. 243

-- 
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list