[ECOS] redboot install on ipaq 3600

Sean Moss-Pultz sean@moss-pultz.com
Tue Dec 7 14:47:00 GMT 2004


This is my first post to this list. I've done my best to search google  
and other resources but they all end up dry. Hopefully somebody can  
help me.

I have an iPAQ 3600. I starting to install RedBoot on it (all files  
from http://sources.redhat.com/ecos/boards/redbootbins/ipaq/) and ran  
into some problems. Basically I tried to use the LCM keypad and since  
it wasn't calibrated correctly I mistyped a command. I'm sorry but I  
don't know exactly which command it was. I didn't save the output. Then  
I tried to retype the first command (lo -r -b 0x100000 redboot_ROM.bin)  
and this also caused more errors. Basically along the lines of it  
cannot format. So I re-flashed my device by downloading the flash  
install from HP. This worked fine. I figured I could now try to install  
RedBoot again. Here is my (unfortunate) output:
------------------------------------------------------------------------ 
-----------------------------------------------------
+FLASH: 0x50000000 - 0x51000000, 64 blocks of 0x00040000 bytes each.
FLASH configuration checksum error or invalid key
... Waiting for network card: ..........No network interfaces found

RedBoot(tm) bootstrap and debug environment - built 09:51:53, Jun 22  
2001

Platform: Compaq iPAQ Pocket PC (StrongARM 1110)
Copyright (C) 2000, 2001, Red Hat, Inc.

RAM: 0x00000000-0x02000000, 0x0004f000-0x01fb0000 available
RedBoot>

------------------------------------------------------------------------ 
-----------------------------------------------------
I figured maybe I could proceed so I just entered the first command  
again:

(lo -r -b 0x100000 redboot_ROM.bin)
and here is the output:
------------------------------------------------------------------------ 
-----------------------------------------------------
RedBoot> lo -r -b 0x100000 redboot_ROM.bin
... Erase from 0x00080000-0x00000000:
... Unlock from 0x00040000-0x00093d48: ..
... Erase from 0x00040000-0x00093d48: Err = 200020

    initialization failed 0x00040000: 0x2(Error trying to erase)
... Lock from 0x00040000-0x00093d48: Err = 500050
------------------------------------------------------------------------ 
-----------------------------------------------------

I have searched for solutions for these error messages and it has lead  
nowhere. Does any one have an idea?

Thanks in advance!

Sean
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 2367 bytes
Desc: not available
URL: <http://sourceware.org/pipermail/ecos-discuss/attachments/20041207/268dfbcc/attachment.p7s>


More information about the Ecos-discuss mailing list