[ECOS] Problem with V850 serial interface

fazio@planetek.it fazio@planetek.it
Thu Dec 2 15:36:00 GMT 2004


Dear Andrew,
I'm in Cristoforo Abbattista staff.
We have redboot running on DEBUG port (dev/ser0).
What do you mean when you say "putting a break point in the ISR/DSR"?
We have 2 serial port, one for gdb or minicom and the other connected to the cam. The 
problems are on the ones connected to the cam. It seems the V850 sends bytes 
correctely but doesn't send some signals necessary to wake up the cam from the sleep 
state.
It is clear now?
Teresa

On 2 Dec 2004 at 15:19, Andrew Lunn wrote:

> On Thu, Dec 02, 2004 at 03:12:01PM +0100, Cristoforo Abbattista wrote:
> > Andrew
> > we are using the full driver and the setting of the parameters is oK.
> > 
> > Thanks
> > Other hints?
> 
> Do you have redboot running? Does the serial port work OK for redboot? 
> 
> Do you get any interrupts from the device? Try putting a break point
> in the ISR/DSR etc. 
> 
> How many serial ports do you have? When debugging problems like this
> its useful to have two, one for gdb and the other for the application
> to use. Or run gdb over a network connection if you have one.
> 
>         Andrew
> 
> -- 
> Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
> and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss


************************************ 
Dott.ssa Teresa FAZIO 
 Planetek Italia s.r.l.
 Via Massaua, 12   I-70123 Bari
 Tel.: +39 080 5343750  - Fax: +39 080 5340280
 fazio@planetek.it
 Web: http://www.planetek.it

************************************



-- 
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list