[ECOS] Atmel eb55 redboot problem

Lorenzo Midulla l.midulla@libero.it
Sun Aug 22 15:26:00 GMT 2004


I have a problem with redboot on Atmel EB55 eval board.

I built redboot (RAM version) from cvs ecos tree.
I loaded it into the board via OCD Commander + wiggler.

Before giving download command I ran the following script for settting up
EBI controller:

endian little
speed 2
word 0xffe00000 = 0x01002529   ;CSR0
word 0xffe00004 = 0x02002121   ;CSR1
word 0xffe00020 = 0x00000001   ;remap
word 0xffe00024 = 0x00000000   ;standard read
CPSR = 0xd3

I connected a terminal on the serial port 0 and I saw the redboot initial
message.
After a while (few seconds) the board was executing the "led swing example"
in the FLASH. For some reason the board reset.

I supposed this was because of watchdog intervention so I created a modified
version of redboot (with watchdog disabled) but the problem remained. I also
tried with the pre-built redboot elf file on the cvs but the result was the
same.

Any ideas?

Thanks,
Lorenzo Midulla





-- 
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list