[ECOS] RE: Re:Re: connect eCos to RedBoot

Muna Hummady muna_hummady@yahoo.com
Wed Aug 11 12:28:00 GMT 2004


--- Nick Garnett <nickg@ecoscentric.com> wrote:

> Muna Hummady <muna_hummady@yahoo.com> writes:
> 
> > --- vibra <vibra@263.sina.com> wrote:
> > 
> > > > 1- I'm building the example program image on
> > > floppy
> > > > disk and trying to load it from RedBoot and
> > > running it
> > > > using 
> > > > 
> > > > load -m  disk basic1.bin
> > > > 
> > > > or 
> > > > 
> > > > load
> > > > 
> > > > or
> > > > 
> > > > load basic1.bin
> > > > 
> > > > I'm failed to loading it . Could you tell me
> how?
> > > You must make sure that the network connection
> of
> > > your Redboot has been configure correctly.  
> > > Anyway, you can also choose gdb to upload the
> bin
> > > via serial.
> > >  
> > > > 2-have you debug any example program using gdb
> by
> > > > connecting the host target to RedBoot via
> serial?
> > > > 
> > > > I could'nt do that.
> > > > 
> > > > If so, Could tell me how?
> > > Start the i386-elf-gdb, then
> > > gdb>set remotebaud 38400 (set serial baudrate)
> > > gdb>target remote /dev/ttyS0 (use COM1 connect
> to
> > > target)
> > > gdb>load hello  (load elf-format object)
> > > 
> > > Good luck!
> > > 
> > > 
> > >
> >
>
===================================================================
> > > hello
> > sorry for re-asking you but there is something
> > missing.
> > 
> > 1- I want to connect eCos to RedBoot via serial.
> >    When I'm trying to use the GDB as you said in  
> 
> > point(2) the is done but When I'm trying to run it
> > using (continue), the redboot is halted and then I
> > could do nothing than restart it.
> 
> As has been said before, try running some of the
> standard tests and
> check that they work before running your own
> programs. Nobody else has
> these problems so it is either in your program or in
> the hardware of
> your target. Why don't you try building and running
> the tm_basic
> kernel test program and post the output from the GDB
> session here.
> 
> > 
> > In addition, I found that I have a problem that I
> must
> > enable (CYGPKG_IO_SERIAL_DEVICES).
> > When trying to enable it using
> >      ecosconfig add CYGPKG_IO_SERIAL_DEVICES
> > told me that it is'nt package
> 
> I don't know where you got this package name from,
> the correct name is
> CYGPKG_IO_SERIAL.
> >            
> >  2- I want to try build the program image on
> floppy
> > using commands you tell me before. I'm booting
> RedBoot
> > from floppy to RAM and then released the RedBoot
> > floppy and put the floppy that have the program
> image 
> > (basic.bin) file. Then, I'm trying to load it
> using
> > 
> > redboot> load -m disk redboot.bin
> > or
> > redboot> load
> > or else
> > but I coudn't.
> > Please tell me is my way true and what is the
> wrong in
> > it? And What is the solution?
> 
> That will not work, there is currently no support in
> RedBoot for
> loading files from floppy. They must either be
> downloaded via the
> serial line or fetched from a TFTP server.
> 
> -- 
> Nick Garnett                    eCos Kernel
> Architect
> http://www.ecoscentric.com/     The eCos and RedBoot
> experts
> 
> 
hello

 1-The(CYGPKG_IO_SERIAL_DEVICES)is defined in ecos.ecc
to enable the device drivers. I found that I must
enable this component in on of the ecos-discuss
mailing list.
the CYGPKG_IO_SERIAL is enabled but that component is
disabled.

2-how can I fetch any test program from a TFTP server

                              thanks
                             muna
 

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 

-- 
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list