[ECOS] Application hangs on ARM Integrator

Henrik Mau Henrik.Mau@sli-institute.ac.uk
Tue Apr 27 16:28:00 GMT 2004


I am new to eCos and my problem may be very trivial.
Every application I try to run on eCos hangs before the first breakpoint 
is reached. I have tried using the "two-threads" example as well as the 
"hello world" example that can be found in the repository, but they hang 
as well.
The tool-chain and the repository I have copied from Massa, Anthony J. 
"Embedded software development with eCos"
The target is an ARM Integrator development board with a ARM7TDMI on it.

Every now and then I get a SIGBUS error instead and I tried to trace in 
the code where it happened. All I found out was that it happened before 
the hal_hardware_init function and I couldn't find out where to add a 
breakpoint earlier in the code.

I have now updated the repository with the latest snapshot, but every 
application still hangs.

I have found a few related posts here on the message board, but the 
suggested solutions have not solved my problem.

Can someone help me with what I might be doing wrong?

Henrik


-- 
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list