[ECOS] MPC555 compile error on latest version

Gary Thomas gary@mlbassoc.com
Thu Apr 22 07:08:00 GMT 2004


On Wed, 2004-04-21 at 10:52, Dragos Carp wrote:
> Hello everybody,
> 
> I tried to recompile the Pyhtec MPC555 adaptation with the latest 
> version of ecos from eCosΒ’ cvs server 
> (:pserver:anoncvs@ecos.sourceware.org:/cvs/ecos), but I get some compile 
> errors in MPC5xx. There are more obvious C errors using a struct in 
> ecos/packages/hal/powerpc/mpc5xx/current/src/var_intr.c (lines 259, 275, 
> etc.). I thought that the latest version in ecos can always be compiled. 
> Considering that IΒ’m new to ecos, is there a rule or trick (in this 
> direction) that I donΒ’t know?

I think this depends on your compiler version.  I just checked it with
GCC-3.3.2 and found a couple of errors.  I just checked in the patches
to fix this so at least it builds with the newer compiler.

Try updating from CVS and see if it helps.

-- 
Gary Thomas <gary@mlbassoc.com>
MLB Associates


-- 
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list