[ECOS] Building an HTTP server as an eCos application

Bier Meister bier.meister@freenet.de
Thu Oct 23 06:46:00 GMT 2003


synthetic target -> linux

Gary Thomas wrote:

>On Wed, 2003-10-22 at 11:33, Bier Meister wrote:
>  
>
>>I am trying to build an HTTP server as an eCos application according to 
>>the example in http://www.mlbassoc.com/examples/build_httpd.html
>>
>>However, during the  building of the application, i get this errors:
>>
>>
>>meister@plain_pc:~/programming/work/httpd_test/httpd_application> make
>>make -C ../libhttpd-1.3/src -f Make.eCos HOME=`pwd`
>>make[1]: Entering directory 
>>`/home/meister/programming/work/httpd_test/libhttpd-1.3/src'
>>make[1]: `libhttp.a' is up to date.
>>make[1]: Leaving directory 
>>`/home/meister/programming/work/httpd_test/libhttpd-1.3/src'
>>gcc -g -nostdlib -Wl,--gc-sections -Wl,-static 
>>-L/home/meister/programming/work/httpd_test/ecos_kernel/install/lib 
>>-Ttarget.ld test_httpd.o -L../libhttpd-1.3/src -lhttp -o test
>>/home/meister/programming/work/httpd_test/ecos_kernel/install/lib/libtarget.a(net_bsd_tcpip_ip_icmp.o)(.bss.cyg_icmpstat+0x0): 
>>In function `ip_next_mtu':
>>/opt/ecos/ecos-2.0/packages/net/bsd_tcpip/v2_0/src/sys/netinet/ip_icmp.c:129: 
>>multiple definition of `cyg_icmpstat'
>>/home/meister/programming/work/httpd_test/ecos_kernel/install/lib/libtarget.a(net_bsd_tcpip_udp_usrreq.o)(.bss.cyg_icmpstat+0x0):/opt/ecos/ecos-2.0/packages/net/bsd_tcpip/v2_0/src/sys/netinet/udp_usrreq.c:140: 
>>first defined here
>>/home/meister/programming/work/httpd_test/ecos_kernel/install/lib/libtarget.a(net_bsd_tcpip_tcp_input.o)(.bss.cyg_icmpstat+0x0): 
>>In function `tcp_newreno':
>>/opt/ecos/ecos-2.0/packages/net/bsd_tcpip/v2_0/src/sys/netinet/tcp_input.c:155: 
>>multiple definition of `cyg_icmpstat'
>>/home/meister/programming/work/httpd_test/ecos_kernel/install/lib/libtarget.a(net_bsd_tcpip_udp_usrreq.o)(.bss.cyg_icmpstat+0x0): 
>>first defined here
>>test_httpd.o(.text.httpd_test+0x9): In function `strdup':
>>/home/meister/programming/work/httpd_test/ecos_kernel/install/include/cyg/libc/stdio/stdio.inl:110: 
>>undefined reference to `CYGACC_CALL_IF_MONITOR_VERSION'
>>collect2: ld returned 1 exit status
>>make: *** [test] Error 1
>>meister@plain_pc:~/programming/work/httpd_test/httpd_application>
>>
>>
>>
>>Have I missed a compiler flag?
>>Can someone please point me to the right direction?
>>    
>>
>
>What's the target platform?
>
>  
>



-- 
Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
and search the list archive: http://sources.redhat.com/ml/ecos-discuss



More information about the Ecos-discuss mailing list