[ECOS] New to eCos, struggling with RedBoot

Michael Trozzo trozzo@arcor.de
Mon Oct 13 16:40:00 GMT 2003


Thanks for the link. Their latest version does run on XP.

I downloaded it, wrote to the floppy, and put the floppy in the target
machine. What´s happening now is this: I get slightly more than two rows
of dots out to the screen, and then it sits there with a blinking
cursor. I did this with the binary I compiled in eCos under Linux and
also with the precompiled binary I downloaded from RedHat. 

Also, I´m not clear on one other thing: Do I need BOTH a serial cable
AND an Ethernet link, or will just the serial link on COM1 do the trick?



-----Original Message-----
From: ecos-discuss-owner@sources.redhat.com
[mailto:ecos-discuss-owner@sources.redhat.com] On Behalf Of Denis
Rouleau
Sent: Samstag, 11. Oktober 2003 01:25
To: Michael Trozzo; ecos-discuss@sources.redhat.com
Subject: RE: [ECOS] New to eCos, struggling with RedBoot


Hi Mike,
	I  just went through these steps a few days ago and found out
that the problem is with cygwin. It is actually a FAQ (sorry I don't
have the
reference)

I circumvented the problem by using a win utility called rawwritewin
that I found on the net instead of dd and it worked just fine.
(http://uranus.it.swin.edu.au/~jn/linux/rawwrite.htm)

You might want to find another one for XP though.

Good luck.

Denis Rouleau



 -----Message d'origine-----
De : 	ecos-discuss-owner@sources.redhat.com
[mailto:ecos-discuss-owner@sources.redhat.com]  De la part deMichael
Trozzo
Envoyé :	Friday, October 10, 2003 6:49 PM
À :	ecos-discuss@sources.redhat.com
Objet :	[ECOS] New to eCos, struggling with RedBoot

Hello,

I´ve just started learning eCos and am using the book "Embedded Software
Development with eCos" by Anthony J. Massa. I´m trying to set up a
RedBoot floppy on an i386 PC target.

I´m working on a laptop that does not have a floppy drive, and am trying
to use a floppy drive that resides on a network share.  The laptop has a
dual boot system with XP and Linux.  I´ve been able to mount the drive
using Cygwin under XP, and also under Linux.  However, when I run the
command to install to the floppy, it doesn´t work. Below are the steps I
have taken, copied from the Cygwin window.

I may be missing something obvious, but I don´t know. If anyone has
advice, I´d definitely appreciate it!

TIA,

Mike Trozzo



Mike@LAPTOP /cygdrive/d
$ mount -f -b //./h: /dev/fd0  <<<--- h: is the local mapping of the
floppy

Mike@LAPTOP /cygdrive/d
$ dd conv=sync if=redboot1_install/bin/redboot.bin of=/dev/fd0
dd: opening `/dev/fd0': No such file or directory

Mike@LAPTOP /cygdrive/d
$ mount
C:\cygwin\bin on /usr/bin type system (textmode)
C:\cygwin\lib on /usr/lib type system (textmode)
C:\cygwin on / type system (textmode)
\\.\h: on /dev/fd0 type system (binmode)   <<<<--- no such file or
dir???
c: on /ecos-c type user (textmode)
c: on /ecos-c type system (binmode)
d: on /cygdrive/d type user (textmode,noumount)
g: on /cygdrive/g type user (textmode,noumount)
h: on /cygdrive/h type user (textmode,noumount)

Mike@LAPTOP /cygdrive/d
$ umount /dev/fd0

Mike@LAPTOP /cygdrive/d
$ mount -f -b //office/a /dev/fd0  <<<<--- the path to the share; same
destination as h:

Mike@LAPTOP /cygdrive/d
$ dd conv=sync if=redboot1_install/bin/redboot.bin of=/dev/fd0
dd: opening `/dev/fd0': No such file or directory

Mike@LAPTOP /cygdrive/d
$ ls
System Volume Information  redboot1_build    redboot1_mlt
redboot1.ecc               redboot1_install  test    <<<--- I made a dir
called test to attempt to install tthere

Mike@LAPTOP /cygdrive/d
$ dd conv=sync if=redboot1_install/bin/redboot.bin of=test
dd: opening `test': File exists   <<-----but nothing else happens!

Mike@LAPTOP /cygdrive/d
$ dd conv=sync if=redboot1_install/bin/redboot.bin of=h:
dd: opening `h:': File exists  <<-----but nothing else happens!

Mike@LAPTOP /cygdrive/d
$ cd ..

Mike@LAPTOP /cygdrive
$ cd h

Mike@LAPTOP /cygdrive/h
$ ls
etst.txt   <<<---test file



--
Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
and search the list archive: http://sources.redhat.com/ml/ecos-discuss


---
Incoming mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.524 / Virus Database: 321 - Release Date: 10/6/03

---
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.524 / Virus Database: 321 - Release Date: 10/6/03


-- 
Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
and search the list archive: http://sources.redhat.com/ml/ecos-discuss




--
Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
and search the list archive: http://sources.redhat.com/ml/ecos-discuss



More information about the Ecos-discuss mailing list