[ECOS] Scheduler Problem

James Yates j.yates@quartzuk.com
Mon Oct 13 11:54:00 GMT 2003


Gary,

   Ho I haven't run any of the test programs. Are these built with the same memory model. Because I am using a custom bootloader due to project requirements everything has to be placed exactly right. Also I have just noticed that when corrupted output is sent to my serial port once cyg_scheduler_start() is called, pressing enter on the terminal causes another line of corrupted out to appear. I think perhaps a rom monitor stub is in the way? I tried disabling all gdb_stub related options but now get no diag output. :-(

I will keep at it. Thansk for your help. If you think of anything else I would be very appreciative.

		James

-----Original Message-----
From: Gary Thomas [mailto:gary@mlbassoc.com]
Sent: 13 October 2003 12:49
To: iz@vsr.si
Cc: James Yates; ecos-discuss@sources.redhat.com
Subject: Re: [ECOS] Scheduler Problem


On Mon, 2003-10-13 at 05:26, Iztok Zupet wrote:
> On Monday 13 October 2003 13:20, James Yates wrote:
> > I have just ported eCos to my own custom SH2 platform and I am now at the
> > point of  getting a simple app up and running. I have a bootloader running

 ... snip
> 
> You should start the scheduler here, otherwise it's never started:
> 
>     	Cyg_Scheduler::scheduler.start(); 	// This function never returns

Or, since this is probably just a C program (not C++)
	cyg_scheduler_start();

Also, James - have you run any of the standard eCos test programs?
They are there to test the behaviour of a port and can tell you a
lot about what works (and what doesn't).

-- 
Gary Thomas <gary@mlbassoc.com>
MLB Associates


--
Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
and search the list archive: http://sources.redhat.com/ml/ecos-discuss



More information about the Ecos-discuss mailing list