[ECOS] Strange error compiling jffs2 (fs-ecos.c)

Andrew Lunn andrew@lunn.ch
Tue Oct 7 23:06:00 GMT 2003

On Wed, Oct 08, 2003 at 11:29:40AM +1300, Charles Oram wrote:
> Hi there,
> I'm trying to build eCos for the IXDP425 board and everything worked
> fine until I added the jffs2 package. Make now reports an error, but the
> compiler only reports warnings and no output file is created by the
> compiler.
> I'm using the latest version of eCos (updated this morning) from anoncvs
> and GCC 3.3 (GNUPro tools 030630) on Redhat 9.
> The output from running 'make' in the build/fs/jffs2/current directory
> is shown below (I get the same error doing the build from configtool).
> Does anyone know what I am doing wrong?
> arm-elf-gcc -c  -I/home/charles/ecos/ixdp425_install/include
> -I/home/charles/ecos/packages/fs/jffs2/current
> -I/home/charles/ecos/packages/fs/jffs2/current/src
> -I/home/charles/ecos/packages/fs/jffs2/current/tests -I.
> -I/home/charles/ecos/packages/fs/jffs2/current/src/ -mcpu=xscale
> -mbig-endian -Wall -Wstrict-prototypes -Winline -Wundef
> -Woverloaded-virtual -g -O2 -ffunction-sections -fdata-sections
> -fno-rtti -fno-exceptions -fvtable-gc -finit-priority -mapcs-frame
> -D__ECOS -nostdinc -iwithprefix include -Werror -Wp,-MD,src/fs-ecos.tmp


Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
and search the list archive: http://sources.redhat.com/ml/ecos-discuss

More information about the Ecos-discuss mailing list