[ECOS] second alarm not triggering

Mahesh mahesh@cranessoftware.com
Tue Oct 7 12:08:00 GMT 2003


     Hi Robert,
               Thanks once again for ur reply.
               second alarm is added to the counter.I have debugged till
 here.But the tick function is not called at all.I have put breakpoints
 at ISR and also at DSR. Once the first alarm is triggered,control is not
 at all going to ISR or DSR and hence not to tick function.
 How can i debug it step by step.
 Thanks and Regards
 Mahesh
 
 On Tue, 2003-10-07 at 14:24, Robert Cragie wrote:
 > Did you try out my suggestions below? It is easy to debug using SID - just
 > put a breakpoint in the ISR using GDB/Insight and then single-step. You can
 > even get SID to trace every instruction it calls although it does run rather
 > slowly.
 > 
 > Robert Cragie, Design Engineer
 > _______________________________________________________________
 > Jennic Ltd, Furnival Street, Sheffield, S1 4QT,  UK
 > http://www.jennic.com  Tel: +44 (0) 114 281 2655
 > _______________________________________________________________
 > 
 > -----Original Message-----
 > From: Robert Cragie [mailto:rcc@jennic.com]
 > Sent: 01 October 2003 11:49
 > To: Mahesh
 > Subject: RE: [ECOS] second alarm not triggering
 > 
 > 
 > I have had no problems in the past using SID built for PID target apart from
 > the fact that delays are stretched considerably. Have you tried reducing the
 > intervals to see if it works? Try running the 'twothreads' example and see
 > if that works. If it does, you must be doing something wrong in your
 > application code. If it doesn't work, check the operation of the simulated
 > timers in SID, check you are getting interrupts by looking at Timer ISR/DSR,
 > then check whether tick is being called.
 > 
 > Note that I have not used SID/eCos together for a while so perhaps things
 > have changed. If I get the chance I will try to rebuild SID/eCos system and
 > do my own tests but it will be unlikely this week.
 > 
 > Robert Cragie, Design Engineer
 > 
 > Direct: +44 (0) 114 281 4512
 > _______________________________________________________________
 > Jennic Ltd, Furnival Street, Sheffield, S1 4QT,  UK
 > http://www.jennic.com  Tel: +44 (0) 114 281 2655   Confidential
 > _______________________________________________________________
 > 
 > > -----Original Message-----
 > > From: ecos-discuss-owner@sources.redhat.com
 > > [mailto:ecos-discuss-owner@sources.redhat.com]On Behalf Of Mahesh
 > > Sent: 01 October 2003 09:08
 > > To: Robert Cragie
 > > Cc: ecos
 > > Subject: RE: [ECOS] second alarm not triggering
 > >
 > >
 > > Hi,
 > >   Sorry for not giving the details.
 > >          I am using eCos for Arm pid target.I am using sid for printf's
 > > .I am working on PC only not on board.In my code i have 5 threads being
 > > created in cyg_user_start function.Alarm's are being used by the threads
 > > for some tasks.I am using real time clock for alarms.tick function is
 > > called after the scheduler is started,but once the first alarm is
 > > triggered,tick function is not called at all.So my second
 > > alarm(different from first one) is not triggering and the program is
 > > getting stuck.
 > > Plz reply for this mail.
 > > Thanks and Regards
 > > Mahesh
 > >
 > >
 > > On Wed, 2003-10-01 at 13:17, Robert Cragie wrote:
 > > > Nothing like enough information. You can't expect any help from
 > > what you've
 > > > written. Give detailed examples of failing source code, target system,
 > > > configuration etc. etc.
 > > >
 > > > Robert Cragie, Design Engineer
 > > >
 > > > Direct: +44 (0) 114 281 4512
 > > > _______________________________________________________________
 > > > Jennic Ltd, Furnival Street, Sheffield, S1 4QT,  UK
 > > > http://www.jennic.com  Tel: +44 (0) 114 281 2655   Confidential
 > > > _______________________________________________________________
 > > >
 > > > > -----Original Message-----
 > > > > From: ecos-discuss-owner@sources.redhat.com
 > > > > [mailto:ecos-discuss-owner@sources.redhat.com]On Behalf Of Mahesh
 > > > > Sent: 01 October 2003 06:12
 > > > > To: ecos
 > > > > Subject: [ECOS] second alarm not triggering
 > > > >
 > > > >
 > > > > Hi,
 > > > >    My first alarm is triggered but the second alarm is not
 > > triggering at
 > > > > all.After the first alarm is triggered the tick function is not called
 > > > > at all.What may be problem?
 > > > > Thanks and Regards
 > > > > Mahesh
 > > > >
 > > > >
 > > > > _______________________________________________
 > > > > This email with any attachments is for the exclusive use of
 > > the intended
 > > > > recipient/s & may contain confidential & legally privileged
 > > information.
 > > > > If you are not the intended recipient pls notify the sender
 > > immediately
 > > > > & delete the email from your system. Any unauthorised use, disclosure,
 > > > > printing, dissemination, forwarding or copying of this mail
 > > is strictly
 > > > > prohibited and unlawful.
 > > > > Visit us at : http://www.cranessoftware.com
 > > > >
 > > > >
 > > > >
 > > > > --
 > > > > Before posting, please read the FAQ:
 > http://sources.redhat.com/fom/ecos
 > > > and search the list archive: http://sources.redhat.com/ml/ecos-discuss
 > > >
 > > >
 > >
 > >
 > --
 > Mahesh M Patil
 > Software Engineer
 > Cranes Software International Limited
 > VasanthNagar
 > Bangalore
 > Mobile:9845579634
 > Office:2381741/2/3 Extn:234
 > 
 > 
 > _______________________________________________
 > This email with any attachments is for the exclusive use of the intended
 > recipient/s & may contain confidential & legally privileged information.
 > If you are not the intended recipient pls notify the sender immediately
 > & delete the email from your system. Any unauthorised use, disclosure,
 > printing, dissemination, forwarding or copying of this mail is strictly
 > prohibited and unlawful.
 > Visit us at : http://www.cranessoftware.com
 > 
 > 
 > 
 > --
 > Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
 > and search the list archive: http://sources.redhat.com/ml/ecos-discuss
 > 
 > 
 > 
 > -- 
 > Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
 > and search the list archive: http://sources.redhat.com/ml/ecos-discuss
 > 
 > 
 -- 
 Mahesh M Patil
 Software Engineer
 Cranes Software International Limited
 VasanthNagar
 Bangalore
 Mobile:9845579634
 Office:2381740/1/2 Extn:234
 www.cranessoftware.com	


_______________________________________________
This email with any attachments is for the exclusive use of the intended
recipient/s & may contain confidential & legally privileged information.
If you are not the intended recipient pls notify the sender immediately
& delete the email from your system. Any unauthorised use, disclosure,
printing, dissemination, forwarding or copying of this mail is strictly
prohibited and unlawful.
Visit us at : http://www.cranessoftware.com



-- 
Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
and search the list archive: http://sources.redhat.com/ml/ecos-discuss



More information about the Ecos-discuss mailing list