[ECOS] IXDP425 vs. IXP420 based board

Sleepy sleepy@maximumunix.org
Mon Oct 6 17:43:00 GMT 2003


I have tried rebuilding the sources for redboot, this fails on both
development board and target board.the only binary that I got to work was
the redboot.bin from the ixp gateway project off SF.
I am pretty sure my tool chain is working as I have compiled and ran a
kernel and ramdisk image.
the main trouble I am having is that I am developing on a linux platform,
and the changes I made seems to result in conflict. as an example, I
removed the NET IO and eth drivers from redboot cdl and resulted in
libtarget not getting built because the code in net/net_io.c uses these
functions.the net code should not have been built.
my question is : is there a way to get redboot built outside of an ecos
environment, is there a way I could "steal" code from redboot and write a
bare minimal initiliazation code that will initialize uart0 and sdram
controller and write "hello world" to the code?
I assume that if i am getting a redboot prompt on the developemtn board
then the uart is initialized, could I still access the address space and
the registers directly or does redboot do any mmu initiliazation?
I am sorry if my questions are dumb, I am new to the xscale and ecos arch,
and i am not so familiar with code at this level.

By the way, if you are experienced with this stuff and you think you could
get it to work, drop me a line, we are looking to make a decision about
contraction this part of development.

Regards
Sleepy


------------------------------------------------------------------------------
Do you Unix?
------------

http://www.maximumunix.org Network Consulting, Security Research, Embedded
Systems.
------------------------------------------------------------------------------

On Mon, 6 Oct 2003, Gary Thomas wrote:

> On Sun, 2003-10-05 at 19:58, Sleepy wrote:
> > Hi
> > I have a board based on the ixdp425 from intel.
> > the main differences are that this board uses one uart, supports up to 8MB
> > flash, and has a ixp420 cpu.
> > I have written redboot to a flash chip, this chip boots and functions
> > correctly the IXDP425 development board, but I got flash checksum error or
> > invalid key on the target board, the code seems to be going through the
> > flash doing a checksum or something, and everyonce in a while it will
> > print the same error message, but i never got a redboot prompt.
> > are there major differences between the two cpu's?
> > any tips on how could I debug this?
> > is there any simple boot code that i can burn to the flash to verify basic
> > hardware operations are working?
>
> The fact that you get any messages at all says that RedBoot is starting
> to work.  The message you got about FLASH checksum error is just a
> warning, telling you that you've not yet initialized your 'fconfig' data
> in FLASH.  Once you get to a prompt, use "fc -i" to set this.
>
> As for why you don't get a prompt, that's harder.  I'd try putting some
> calls to diag_printf() in .../redboot/current/src/main.c and try and
> follow the initialization and see where it hangs up.
>
> --
> Gary Thomas <gary@mlbassoc.com>
> MLB Associates
>
>
> --
> Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
> and search the list archive: http://sources.redhat.com/ml/ecos-discuss
>
>

-- 
Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
and search the list archive: http://sources.redhat.com/ml/ecos-discuss



More information about the Ecos-discuss mailing list