[ECOS]Tcp Stack problems - CVS

kevin_lemay@agilent.com kevin_lemay@agilent.com
Fri Nov 14 18:48:00 GMT 2003


I had to remove the enclosures to get this through to the list. I can send them separately if needed.

Kevin

-----Original Message-----
From: LEMAY,KEVIN (A-Roseville,ex1) 
Sent: Friday, November 14, 2003 10:43 AM
To: ecos-discuss@sources.redhat.com
Subject: [ECOS]Tcp Stack problems - CVS


I am trying to get a TCP/IP application running on eCos. Everytime that eCos sets up a client socket and sends data, the socket is reset from eCos as soon as the ACK is received from the other system.

I have a windows echo server executable in the zip file, and the client eCos code, makefile and ecc file used to make the ecos image. (ecc based on Nov 7th CVS version)

I also am enclosing an ethernet trace. Line 151 shows the socket being connected. The data is sent on line 158, echoed data on 160 followed by the ecos reset on 161.

I tried this with both windows and linux servers with the same result. I also tried the 2.0 release with similar results.

Does anyone have a clue of what I may be doing wrong?

The tcp_io_test seems to run OK.

Thanks for any help,

Kevin

PS. I am inclosing the windows server source, in case you wanted to look at it.

--
Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
and search the list archive: http://sources.redhat.com/ml/ecos-discuss



More information about the Ecos-discuss mailing list