[ECOS] Redboot exception

Nick Garnett nickg@ecoscentric.com
Wed Nov 12 13:01:00 GMT 2003

<kevin_lemay@agilent.com> writes:

> FYI,
> After rebuilding the redboot image from the CVS archive as of Nov
> 7th, I now get the following error after downloading the image via
> GDB on an i386.
> Program received signal SIGFPE, arithmetic exception
> Package/net/common/current/src/getserv.c

Where exactly in getserv.c is this failing? I cannot see any FP
activity in this file at all. What is the rest of the message from
GDB? What location in your executable does the PC point to? Is there
FP code there?

What program are you running? Have you tried any of the standard tests
programs -- fptest in particular? How have you configured the

Nothing has changed in this area for over a year, so it is unlikely
that there are any changes between v2.0 and the current CVS tree that
would have any effect.

> I tried several diskettes and verified that the application runs
> using the previous version (2.0) of redboot.
> I rebuilt from scratch again and noticed that the lazy FPU switching
> was disabled after loading the .ecm. I re-enabled it and it now
> works properly.

Lazy FPU switching should not be enabled in RedBoot, otherwise it is
possible that the FPU does not get saved during exception processing,
which would confuse GDB.

Nick Garnett                    eCos Kernel Architect
http://www.ecoscentric.com      The eCos and RedBoot experts

Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
and search the list archive: http://sources.redhat.com/ml/ecos-discuss

More information about the Ecos-discuss mailing list