[ECOS] Flash detection

M.Eugenia G.Valdecasas valdecasas@isar-tec.com
Mon Nov 10 14:56:00 GMT 2003


Hi, I recompiled redboot to use in our board. It has a PXA255 processor
with 2x16 Intel 28F128J3 Flash. I use the strata flash drivers from 
intel. 
I upload redboot to the board with the JTAG tools but on starting comes 
an error message:


+Can't identify FLASH, sorry, man e, dev 1e, id [<Not a string: 
0xA000CAFC>] stat 0
A000CAEC: 0E 1E B0 AB 0E 1E C0 AB  0E 1E D0 AB 0E 1E E0 AB 
|................|
A000CAFC: 0E 1E F0 AB 00 00 00 00  00 00 00 00 00 00 00 00 
|................|
A000CB0C: 00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00 
|................|
A000CB1C: 00 00 00 00                                      
|....            |
FLASH: driver init failed: Unknown error

I tried the possible solutions named on the mailing list, like in 
strata.c change the line  "if ( (qp->manuf_code == FLASH_Intel_code)"
for "if(1 ", to define CYGHWR_IO_FLASH_DEVICE_NOT_IN_RAM and to change 
the CNT into a higher value. But I still get the same error and it does 
not go on.

Have anybody any ideas what is it happening?. I would really appreciate 
any help. Thank you in advance,


Dipl. Ing. M.Eugenia G.Valdecasas
_________________________________

Isar-Tec
Software - Digital Systems
Plannegerstr. 32
D-81241 München

Email: valdecasas@isar-tec.com
Web: www.isar-tec.com

-- 
Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
and search the list archive: http://sources.redhat.com/ml/ecos-discuss



More information about the Ecos-discuss mailing list