[ECOS] Very strange: fis create/write fail Err = 92

Xue weihua snowweihua@msn.com
Fri Nov 7 06:20:00 GMT 2003


Hi everyone:
  I have meet a very strange problem on my Intel ixp422 board.
Flash is Intel TE28F128J3C. After do "fis init ",it show like
RedBoot> fis list
Name              FLASH addr  Mem addr    Length      Entry point
RedBoot           0x50000000  0x50000000  0x00040000  0x00000000
RedBoot config    0x50FC0000  0x50FC0000  0x00001000  0x00000000
FIS directory     0x50FE0000  0x50FE0000  0x00020000  0x00000000

Then I can't use "fis create/write" to write flash.

RedBoot> load -r -v -b 0x01008000 zImage
Using default protocol (TFTP)
-
Raw file loaded 0x01008000-0x010bbad3, assumed entry at 0x01008000
RedBoot> fis create kernel -b 0x01008000 -l 0x100000 -f 0x50040000
... Erase from 0x50040000-0x50140000: ........
... Program from 0x01008000-0x01108000 at 0x50040000: Err = 92
                                                                            
                                                 
Can't program region at 0x50040000: Error trying to program

But I can use "fis create/write" on "RedBoot config" or "FIS directory".
so it means hw has no problem. I can write . but only write some sectors. 
It seems these sectors have been done something on by initialize, but I 
don't 
know what it is . I have try "fis unlock " before "fis create/write", it is 
no helpful.

Anyone have some hints on it ?
thanks a lots

_________________________________________________________________
ÓëÁª»úµÄÅóÓѽøÐн»Á÷£¬ÇëʹÓà MSN Messenger: http://messenger.msn.com/cn 


-- 
Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
and search the list archive: http://sources.redhat.com/ml/ecos-discuss



More information about the Ecos-discuss mailing list