[ECOS] reboot go enhancement

Aaron Richardson aarichar@cisco.com
Fri May 30 01:28:00 GMT 2003


er, not quite.  I get this now when I try and load a new program to redboot.

Exiting...


Program completed with status 0
RedBoot>
RedBoot>
RedBoot>
RedBoot> load -v -m y
CCCCCCCCC...........Can't load '<null>': Timed out
RedBoot>

Time has changed somehow for redboot?  Any ideas?

thanks,
Aaron



On Thursday 29 May 2003 01:45 pm, Aaron Richardson wrote:
> Sweet.
>
> I used the following command to return to redboot.  '0' is the return
> status.
>
> CYGACC_CALL_IF_MONITOR_RETURN(0);
>
> Also the reset is working too.
>
> thanks!!!
> Aaron
>
> On Thursday 29 May 2003 11:50 am, Gary D. Thomas wrote:
> > On Thu, 2003-05-29 at 10:45, Aaron Richardson wrote:
> > > I found a thread about a redboot go command enhancement, but Im not
> > > sure how to go about using it.  Any pointers on where to start?  Did
> > > this make into the 2.0, or is it still a patch?
> >
> > It's in the current CVS.
> >
> > > Also I would like to know if there is a way to reset the board from an
> > > ecos application.
> >
> > CYGACC_CALL_IF_RESET();
> >
> > Look at the routine "do_reset()" in
> > .../packages/redboot/current/src/main.c to see how it gets used.
> >
> > --
> > Gary D. Thomas <gary.thomas@mind.be>
>
> --
>
>
> Aaron Richardson
> aarichar@cisco.com
> 512-378-1286

-- 


Aaron Richardson
aarichar@cisco.com
512-378-1286


-- 
Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
and search the list archive: http://sources.redhat.com/ml/ecos-discuss



More information about the Ecos-discuss mailing list