[ECOS] RedBoot load problem

Martin Schoeberl martin.schoeberl@chello.at
Thu May 22 12:02:00 GMT 2003


> > > I'm using an old 486 notebook for first tests. I've installed the eCos
> > > version from the book 'Embedded Software Dev. w. eCos'. Everything
works
> > > fine till the download of the first example via Hyperterminal. The
> download
> > > starts but after about 20KB it stops and host and traget run into
> timeouts.
> > >
> > > Martin
> >
> > I found that I needed to apply this patch to get serial downloads to
> > work in any useful way on my i386 target boards. I'm not sure why they
> > were disabled (I think someone told me but I can't remember that long
> > ago), but everything works fine for me with them turned on.
> >
> > Ian.
>
> The problem has changed: I enabled 'Validate RAM addresses duringload' for
> RedBoot and got the message:
> *** Abort! Attempt to load S-record to address: 0x00108000, which is not
in
> RAM
>
> version shows:
> RAM: 0x00000000-0x000a0000, 0x0008ab30-0x000a0000 available
>
> But the pc has 24MB of ram. How can I change this that RedBoot recognizes
> ram above 0x100000.
>
> Martin

Half a solution:
I disabled 'validate RAM...' again and tried a different PC -> it works.
Tried GDB -> also OK
switched back to my old 486SX and loaded the program with GDB -> also OK!!!

What's the difference from downloading with hyperterm and with gdb?
Why do I have to disable 'validate RAM..' for the pc target?

Martin


-- 
Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
and search the list archive: http://sources.redhat.com/ml/ecos-discuss



More information about the Ecos-discuss mailing list