[ECOS] running twothreads problem

Aaron Richardson aarichar@cisco.com
Thu May 22 04:51:00 GMT 2003


Ok, so I figured out my problem with the context test.  I had tracing on in 
the ecos build and this threw off the test because of all the output that was 
being sent to the screen.  I will need to re-run all the tests again without 
tracing turned on.  However, this was not the problem with the twothreads, 
because I initially tried this without tracing (and prompty found tracing to 
help debug).

Aaron


On Wednesday 21 May 2003 03:31 pm, Gary D. Thomas wrote:
> On Wed, 2003-05-21 at 14:17, Aaron Richardson wrote:
> > Ok.  I am able to build, load, and run an ecos application.  The hello
> > world application is running just fine.  However, when I run the
> > twothreads program the code gets locked up.  I get the following on the
> > console:
> >
> > Entering twothreads' cyg_user_start() function
> > Beginning execution; thread data is 0
> > Beginning execution; thread data is 1
> >
> > I turned on tracing and it doesnt ever come back from idle_thread_main.
> >
> >
> > Also I was able to get some tests running (although not all compile) and
> > several of the first few failed.  Perhaps this points to the same
> > problem? Here are the tests that failed.
> >
> > context
> > bm_sem1
> > bm_sem2
> > clock0
> > clock1(never finishes)
> > clocktruth(never finishes)
>
> First guess is that you're not getting any system clock interrupts.
> This would prevent the clock tests from working, as well as any of
> the others that require multiple threads to be scheduled.
>
> If 'context' doesn't work, you have fundamental scheduling problems.
> I'd get it fixed first.  Then try and see if interrupts work at all,
> etc.  GDB is a handy tool for this.

-- 


Aaron Richardson
aarichar@cisco.com
512-378-1286


-- 
Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
and search the list archive: http://sources.redhat.com/ml/ecos-discuss



More information about the Ecos-discuss mailing list