[ECOS] Redboot configuration

Gary D. Thomas gary.thomas@mind.be
Thu May 15 18:19:00 GMT 2003

On Thu, 2003-05-15 at 10:31, Peter Graf wrote:
> Gary D. Thomas wrote:
> > > I have the problem that, using the Configuration tool "2.12 net" for
> > > Windows, the CYGBLD_REDBOOT_MIN_IMAGE_SIZE and
> > > CYGBLD_REDBOOT_FLASH_BOOT_OFFSET options are wrong when I build Redboot 
> > for
> > > RAM startup. It doesn't seem to matter wether these options are changed by
> > > importing an .ecm file, altered manually by the tool, or by editing the
> > > .ecc file. The actual result in the executable corresponds to the values
> > > supplied redboot.cdl (which are not useful for me).
> > >
> > > My target is a custom PowerPC variant, based on 603e core. I use the 2.0b1
> > > sources. I followed the steps described in chapter 3 "Rebuilding RedBoot",
> > > eCos reference manual. Has someone else noticed this behaviour or could
> > > point me how to use these options?
> > >
> >
> >We modify these all the time from .ecm scripts, so there must
> >be some other problem at work here.
> >
> >If you modify these values, do you see them if you export the
> >configuration?  e.g.
> >   % ecosconfig export cfg
> >The file 'cfg' should show the modified values.
> It does.
> >Of course, don't forget to rebuild your build tree after making the
> >changes.  Using the CLI
> >   % ecosconfig tree
> >
> >Until you do this step, only the configuration database changes, not
> >the actual build.  This includes the "include" files used by the sources
> >to get at the actual values.
> Yes, I know.
> The problem may be that I'm not using the commandline tool (ecosconfig), 
> but the GUI Configuration tool "2.12 net" for Windows (configtool.exe). 
> Maybe it fails to correctly create the build tree? (I tried deleteing the 
> old buildtree to be save, even restarted the tool itself, and tried 
> different tool versions).
> There are a few issues to resolve, before I can actually do the complete 
> build on my NT system using the commandline ecosconfig, e.g. the 
> target-specific toolchain is not in the path (for other reasons). Do you 
> think it is worthwhile to turn away from the GUI tool and use ecosconfig 
> instead?

I personally prefer the CLI version, but that's because I prefer those
sorts of tools.  The GUI tool works just as well.

I just tried exactly what you're asking for, using the ConfigTool as
provided with 2.0 and it seemed to do the right thing.  I imported
a .ecm file which modified these parameters and the appropriate
changes appeared in the <pkgconf/redboot.h> configuration file.

Gary D. Thomas <gary.thomas@mind.be>

Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
and search the list archive: http://sources.redhat.com/ml/ecos-discuss

More information about the Ecos-discuss mailing list