[ECOS] Floppy Image

Yugandhar yugandar@intotoinc.com
Wed May 14 08:07:00 GMT 2003

  I built eCos library for i386 PC. Then i compiled the sample programs in 
examples dir in ecos distribution.I then used the commands 

$fdformat /dev/fd0 - to format a floppy disk
$i386-elf-objcopy -O binary hello app.bin
$dd conv=sync if=app.bin of=/dev/fd0

as specified in the documents.

But when i tried to boot with the floppy disk to test the 'hello' sample 
program,it doesn't happen.

After i get 'Verifying DMI pool data' the system just hangs.

  When i built redboot using configtool and did the above steps on the 
resultant reboot.elf i had the same problem.

I even tried changing the floppy.
What could be wrong.Please advice.


Note:Please ignore previous mails as they contained the wrong address.	

Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
and search the list archive: http://sources.redhat.com/ml/ecos-discuss

More information about the Ecos-discuss mailing list