[ECOS] configtool problems

S Yugandhar yugandar@intotoind.com
Wed May 7 09:13:00 GMT 2003


Hi Gary,
  I built the latest tools,gcc and newlib from source.This solved the 
ecos build problem.However i still get the same error when i try to run the 
'configtool'.Any pointers.

Yugandhar

 On 6 May 2003, Gary D. Thomas wrote:

> Date: 06 May 2003 07:06:35 -0600
> From: Gary D. Thomas <gary.thomas@mind.be>
> To: S Yugandhar <yugandar@intotoind.com>
> Cc: eCos Discussion <ecos-discuss@sources.redhat.com>
> Subject: Re: [ECOS] configtool problems
> 
> On Tue, 2003-05-06 at 02:19, S Yugandhar wrote:
> > Hi,
> >   I am new to this list as i am to ecos.Yesterday, after i downloaded and 
> > installed ecos for i386-elf,i tried to run 'configtool'(after doing things 
> > as described in the documents).I got the following.
> > 
> > configtool: error while loading shared libraries: configtool: symbol 
> > fnmatch, version GLIBC_2.2.3 not defined in file libc.so.6 with link time 
> > reference
> > 
> > I then tried 'ecosconfig'.I used the following commands.
> > 
> > $ecosconfig new pc
> > $ecosconfig tree
> > $make
> > 
> > The output ended with an error...
> > i386-elf-ar: error while loading shared libraries: i386-elf-ar: symbol 
> > fnmatch, version GLIBC_2.2.3 not defined in file libc.so.6 with link time 
> > reference
> > 
> >  What could be the possible reason.Did anyone face a similar 
> > problem earlier.Any help is greatly appreciated.
> 
> What version of Linux are you running on your host?
> 
> These errors imply that the GLIBC that is installed on your system
> is not in step with the one used to build the tools.  Possibly you
> might upgrade your system, or you might have to build the tools
> yourself.
> 
> 


-- 
Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
and search the list archive: http://sources.redhat.com/ml/ecos-discuss



More information about the Ecos-discuss mailing list