[ECOS] PowerPC simulator help request

Nick Garnett nickg@ecoscentric.com
Mon May 5 09:31:00 GMT 2003


"Ashish Thakkar" <ashishvthakkar@hotmail.com> writes:

> Hi,
> 
> I am trying to run an application for PowerPC simulator and I get the
> following output message when I run the application using gdb:
> 
> Starting program: /ecos-c/workdir/application/basic1,exe
> core_find_mapping() - access to unmaped address, attach a default map to
> handle this - addr=0xf000101a nr_bytes=0x1 processor=0xa0bea40 cia=0x4510
> 
> I have no idea what I am supposed to do to correct this. I have tried
> different source files, but I get the same message. Can someone help me with
> this?

You need to supply some arguments to the simulator when you start
it. The following line comes from the ~/.eCosPlatforms/PowerPC-PSIM
file.

target sim -o '/#address-cells 1' -o '/openprom/init/register/pc 0x100' -o '/iobus@0xf0000000/reg 0xf0000000 0x01000000' -o '/iobus/pal@0xf0001000/reg 0xf0001000 32'



-- 
Nick Garnett                    eCos Kernel Architect
http://www.ecoscentric.com/     The eCos and RedBoot experts


-- 
Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
and search the list archive: http://sources.redhat.com/ml/ecos-discuss



More information about the Ecos-discuss mailing list