[ECOS] A Build and a debug question

Gary D. Thomas gary.thomas@mind.be
Mon Mar 24 21:26:00 GMT 2003


On Mon, 2003-03-24 at 13:12, Geoff wrote:
> Hi
> 
> Question 1)
> I am using a PowerPC Viper board, when I build eCos (A version 2 full
> snapshot with new_net package selected) I don't get any errors but lots of
> miscellaneous warnings. Is this normal , I was expecting a fully clean build
> ?

With the network stack there may be a few warnings, but not what
I would call "lots".  What warnings are you seeing?  Which ones
bother you?

> 
> Question 2)
> Having linked eCos to a simple test program I cannot get it to load into gdb
> properly. The error message I get is "gdb-internal-error:
> longest_local_hex_string_custom: insufficient space to store result". Any
> suggestions what I have done wrong here ?

More details, please.  My guess is that you've not linked it
to the correct address (which startup type did you choose)?

-- 
.--------------------------------------------------------.
|       Mind: Embedded Linux and eCos Development        |
|--------------------------------------------------------|
| Gary Thomas              email:  gary.thomas@mind.be   |
| Mind ( http://mind.be )  tel:    +1 (970) 229-1963     |
| gpg: http://www.chez-thomas.org/gary/gpg_key.asc       |
'--------------------------------------------------------'


-- 
Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
and search the list archive: http://sources.redhat.com/ml/ecos-discuss



More information about the Ecos-discuss mailing list