[ECOS] Problem running redboot from eb40a

wkhto@engmail.uwaterloo.ca wkhto@engmail.uwaterloo.ca
Thu Mar 20 17:27:00 GMT 2003


Hi

I got a problem when I try to run redboot from eb40a. I used ecos 2.0 b1 with
Shannon Hollands two tar.gz files to compile the eb40a redboot(RAM). The
compilation is good. When I try to load the elf file by using GDB, GDB stops
during the load process.

Here is the output:

--------------------------------------------------
arm-elf-gdb redboot.elf
GNU gdb 5.3
Copyright 2002 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "--host=i686-pc-linux-gnu --target=arm-elf"...
(gdb) tar rdi s=/dev/ttyS0
Angel Debug Monitor (serial) 1.04 (Advanced RISC Machines SDT 2.5) for AT91EB40A
(1.00)
Angel Debug Monitor rebuilt on Feb 03 2002 at 16:09:59
Serial Rate:   9600
Connected to ARM RDI target.
(gdb) load
Loading section .rom_vectors, size 0x40 lma 0x20000
Loading section .text, size 0xb47c lma 0x20040
--------------------------------------------------

Any suggestions for this problem

Thanks for your help

Wilson


----------------------------------------
This mail sent through www.mywaterloo.ca

-- 
Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
and search the list archive: http://sources.redhat.com/ml/ecos-discuss



More information about the Ecos-discuss mailing list