[ECOS] Build help please ?

Gary D. Thomas gary.thomas@mind.be
Thu Mar 13 16:41:00 GMT 2003


On Thu, 2003-03-13 at 09:33, Geoff wrote:
> Hi
> 
> I am trying to get eCOS to build and run for the first time on a Viper
> PowerPC board. It has got me stumped at the moment, could anyone give me a
> clue what I am doing wrong please ?
> 
> I installed and built from the Viper CD (1.5.16). This built ok but locked
> up or crashed when I tried to run a simple Hello World test program.
> 
> >From a quick phone chat I realised I needed to use a more upto date eCOS
> snapshot that I had not spotted on the 2nd CD.
> When I unpacked "ecos-v2-full-alpha-snap-2003-01-06.tar" and pointed the
> config tool at the new repository it builds some files then fails with
> 
> powerpc-eabi-gcc -c  -I/ecos-c/ecosbuild/ecos1_install/include -I/ecos-e/eco
> ssnap/ecos/packages/hal/powerpc/quicc/current -I/ecos-e/ecossnap/ecos/packag
> es/hal/powerpc/quicc/current/src -I/ecos-e/ecossnap/ecos/packages/hal/powerp
> c/quicc/current/tests -I. -I/ecos-e/ecossnap/ecos/packages/hal/powerpc/quicc
> /current/src/ -msoft-float -mcpu=860 -Wall -Wpointer-arith -Wstrict-prototyp
> es -Winline -Wundef -Woverloaded-virtual -g -O2 -ffunction-sections -fdata-s
> ections -fno-rtti -fno-exceptions -fvtable-gc -finit-priority -Wp,-MD,src/qu
> icc_smc1.tmp -o src/hal_powerpc_quicc_quicc_smc1.o
> /ecos-e/ecossnap/ecos/packages/hal/powerpc/quicc/current/src/quicc_smc1.c
> /ecos-e/ecossnap/ecos/packages/hal/powerpc/quicc/current/src/quicc_smc1.c:14
> 0: `QUICC_BD_BASE' undeclared here (not in a function)
> 
> >From a quick perusal
> 
> QUICC_BD_BASE is defined in
> E:\ECOSSNAP\ECOS\packages\hal\powerpc\quicc\current\include\ppc8xx.h
> 
> but the file
> e:/ecossnap/ecos/packages/hal/powerpc/quicc/current/src/quicc_smc1.c has the
> header include as
> 
> <cyg/hal/quicc/ppc8xx.h> which doesnt look the same path to me, indicating I
> have screwed up the tree structures somehow ?
> 
> By changing the header paths in the *.C file to point to where the headers
> really are, it fixed that one C file compile problem, but then I got similar
> looking problems with other C files. Correcting header paths can't be the
> correct way to fix this, I must have made some mistake in the install, or
> not understanding something ?
> 
> I downloaded and tried with the lastest alpha snaphsot, I got the same error

How did you configure this?  Did you try to just update the sources
and then build?  or have you rerun the config tool (I'm not clear which
one you might be using) after importing the new sources?

This definitely works with the latest snapshots:
  % ecosconfig new viper
  % ecosconfig tree
  % make

-- 
.--------------------------------------------------------.
|       Mind: Embedded Linux and eCos Development        |
|--------------------------------------------------------|
| Gary Thomas              email:  gary.thomas@mind.be   |
| Mind ( http://mind.be )  tel:    +1 (970) 229-1963     |
| gpg: http://www.chez-thomas.org/gary/gpg_key.asc       |
'--------------------------------------------------------'


-- 
Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
and search the list archive: http://sources.redhat.com/ml/ecos-discuss



More information about the Ecos-discuss mailing list