[ECOS] problems compiling host tools

Jonathan Larmour jifl@eCosCentric.com
Fri Mar 7 18:35:00 GMT 2003


Aldo Dolfi wrote:
> Thanks for the hint, but I am still stuck.
> I tried to configure gcc-2.95.3 but it says target i386-pc-elf not 
> supported.
> So I tried 2.95.2 with the patch 
> http://sources.redhat.com/ecos/tools/patches/ecos-gcc-2952.pat
> The configure goes fine, but during the make I get errors about not 
> finding system include files.
> The output from make is attached.
> What's wrong this time? :)

You didn't follow the instructions quite carefully enough I'm afraid. You 
need to use:
make -w all-gcc install-gcc LANGUAGES="c c++"

It looks like you did just "make" or "make all"

Jifl
-- 
eCosCentric    http://www.eCosCentric.com/    The eCos and RedBoot experts
--[ "You can complain because roses have thorns, or you ]--
--[  can rejoice because thorns have roses." -Lincoln   ]-- Opinions==mine


-- 
Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
and search the list archive: http://sources.redhat.com/ml/ecos-discuss



More information about the Ecos-discuss mailing list