[ECOS] ecosconfig build problem

Koeller, T. Thomas.Koeller@baslerweb.com
Mon Mar 3 12:30:00 GMT 2003


Hi,

I just tried to rebuild ecosconfig from source using gcc-3.2.2 and binutils
2.13.2.1 on Linux. While I do not get any errors during the build process,
the resulting executable segfaults consistently. I tried to build with debug
information and debug it, but I could not really find the source of the
problem. I got the impression that something inside libstdc++-v3 does not
work the way it is supposed to (the debugger showed that
std::string(&std::string) did not create a proper copy of the string).
However, I became confused by debugging through all that template stuff.

Anyone having similar problems?

tk
----------------------------------------------- 
Thomas Koeller, Software Development 

Basler Vision Technologies 
An der Strusbek 60-62 
22926 Ahrensburg 
Germany 

Tel +49 (4102) 463-390 
Fax +49 (4102) 463-46390

mailto:Thomas.Koeller@baslerweb.com 
http://www.baslerweb.com 



-- 
Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
and search the list archive: http://sources.redhat.com/ml/ecos-discuss



More information about the Ecos-discuss mailing list