[ECOS] floating point

Nick Garnett nickg@ecoscentric.com
Fri Jan 24 18:23:00 GMT 2003

davidw@dedasys.com (David N. Welton) writes:

> Ok, so I tried a few things to debug it:
> __fpu_switch_vsr:
>         movb $'a',(0xb8000)
> And I don't see it showing up.
> The code to intall __fpu_switch_vsr is getting run, but it
> doesn't seem to set things up quite right.
> This makes things work ok:
> 	hal_pc_exception_noerr  4
> 	hal_pc_exception_noerr  5	
> 	hal_pc_exception_noerr  6
> #	hal_pc_exception_noerr  7
> hal_pc_exception_7:
> 	movl	$0,hal_trap_error_code
> 	pushl	$7
> 	incl	(hal_vsr_stats+7*4)
> 	jmp	__fpu_switch_vsr
> Trying to figure out why it's not setting things up automatically.

The most likely thing is that the VSR is getting re-set to something
else later.

I did some work on the floating point stuff a few months ago to make
stand-alone applications work correctly. 

What version of eCos are you using? The latest repository?
What startup type are you using? Have you tried using a rebuilt

I've just re-tested running RAM apps over RedBoot here with both lazy
and non-lazy FPU switching and it all seems to work OK. Even doing FP
stuff in cyg_start() works.

Nick Garnett - eCos Kernel Architect

Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
and search the list archive: http://sources.redhat.com/ml/ecos-discuss

More information about the Ecos-discuss mailing list