[ECOS] CYGNUM_HAL_RTC_PERIOD / floating point

David N. Welton davidw@dedasys.com
Thu Jan 23 23:28:00 GMT 2003


Jonathan Larmour <jifl@eCosCentric.com> writes:

> > One more thing - I try and set up a floating point variable in my
> > cyg_start, and that seems to futz things up but good.  I had a
> > look in the mailing list archives, and tried a few things like
> > turning off the lazy FPU switching, but to no avail.

> > This is, as usual on a standard i386 PC booting from floppy.

> 386DX? 386SX has no FPU. Does FPU work outside of cyg_start in threads?

This machine is a - what's the term you folks use ? - "bog standard"
modern desktop PC.  I thought of trying it in a variety of places in
the code, and it doesn't seem to work in threads, either.

When I run it under bochs with debug logs turned on, it tells me:

00005904485d[CPU  ] exception(07 h)
00005904485d[CPU  ] interrupt(): vector = 7, INT = 0, EXT = 1
00005904485d[CPU  ] int_trap_gate286(): INTERRUPT TO SAME PRIVILEGE

It doesn't seem to be any problem with bochs, as the same code freezes
up in the same way when just running normally, booted from floppy.

Still looking into it, but any advice would be welcome.

-- 
David N. Welton
   Consulting: http://www.dedasys.com/
     Personal: http://www.dedasys.com/davidw/
Free Software: http://www.dedasys.com/freesoftware/
   Apache Tcl: http://tcl.apache.org/

-- 
Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
and search the list archive: http://sources.redhat.com/ml/ecos-discuss



More information about the Ecos-discuss mailing list