[ECOS] Configtools build

Jonathan Larmour jifl@eCosCentric.com
Mon Jan 20 19:53:00 GMT 2003


Fabrice Gautier wrote:
> Hi,
> 
> I am trying to build the config tools from cvs, on a linux host.
> 
> I succesfully (i think) build the command line tools by doing a
> configure/make in the ecos/host directory.
> 
> Now i'm trying to build the gui tool (version 2). I'm trying to use the
> makefile in ecos/host/tools/configtool/standalone/wxwin and following the
> direction on the website. I'm running into a problem when some files try to
> include cyg/infra/cyg_type.h and other includes from the infra package.
> Where should theses files be included from? In the cvs theres 2 place where
> i can find the infra directory but its never under a cyg/infra directory.
> When we build an ecos configuration the includes files are copied into an
> install directory, should the Makefile for the configtool do the same ?

I believe when you do a configure of the host tools for the command line 
tool it createst a host/infra subdirectory which you can -I. But I'd have 
thought the build scripts were already meant to do this. When I built it 
in the past I didn't have to do anything like that.

> I also tried to modify the makefile so that it uses the wxGtk that's
> allready installed on my system, so I might have broken the makefile in
> other ways...

Pass.

Jifl
-- 
eCosCentric       http://www.eCosCentric.com/       <info@eCosCentric.com>
--[ "You can complain because roses have thorns, or you ]--
--[  can rejoice because thorns have roses." -Lincoln   ]-- Opinions==mine


-- 
Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
and search the list archive: http://sources.redhat.com/ml/ecos-discuss



More information about the Ecos-discuss mailing list