[ECOS] Re: redboot for x86 baced PC

Nick Garnett nickg@ecoscentric.com
Fri Jan 10 12:24:00 GMT 2003


harish.vaidya@philips.com writes:

> >Actually that sounds like it *isn't* trying to boot off the floppy. If it
> >was and failed, it would likely just freeze.
> 
> >Did you definitely copy the .bin image to the floppy correctly? Can you
> >try a different PC? Have you verified the BIOS boot order options?
> 
> As per instructions in the user guide i used "dd" command to copy .bin file into floppy.
> i followed these instructions:
> 1. took a new floppy. formatted using "fdformat /dev/fd0"
> 2. mount -t msdos /dev/fd0 /mnt/floppy

Don't do this. 

> 3. dd conv=sync if=/home/hv/redboot/redboot.bin of=/dev/fd0

I also add bs=512 to that line. But I am not sure it makes any difference

> 4. when i tried "ls /mnt/floppy" it showed some junk characters. that is the contents of floppy.
> so do you suspect anything wrong in copying the file. once i do "dd"
> what should be the contents of floppy.

Do you subsequently unmount the floppy after writing RedBoot? It is
possible that the filesystem writes old content back to the the floppy
and corrupts RedBoot.

> 5. I checked the BIOS boot order options properly. floppy is first.
> 6. rebooted the machine. the rest i have already told.
> 7. same floppy i tried in different machine (windows PC) by changing the boot order as floppy first. but still it does'nt work.
> 
> Meanwhile i will try in other linux machine. do you suspect anything wrong with procedure i followed
>

Try a different floppy. Maybe the one you are using has some bad sectors.

-- 
Nick Garnett - eCos Kernel Architect
http://www.eCosCentric.com/



More information about the Ecos-discuss mailing list