[ECOS] Re: redboot for x86 baced PC

Gary D. Thomas gary.thomas@mind.be
Fri Jan 10 12:00:00 GMT 2003


On Thu, 2003-01-09 at 22:57, harish.vaidya@philips.com wrote:
> 
> 
> 
> >Actually that sounds like it *isn't* trying to boot off the floppy. If it
> >was and failed, it would likely just freeze.
> 
> >Did you definitely copy the .bin image to the floppy correctly? Can you
> >try a different PC? Have you verified the BIOS boot order options?
> 
> As per instructions in the user guide i used "dd" command to copy .bin file into floppy.
> i followed these instructions:
> 1. took a new floppy. formatted using "fdformat /dev/fd0"
> 2. mount -t msdos /dev/fd0 /mnt/floppy

Why did you do this?  You want to copy RedBoot to the floppy in
a RAW format - not as a file in a file system.

> 3. dd conv=sync if=/home/hv/redboot/redboot.bin of=/dev/fd0
> 4. when i tried "ls /mnt/floppy" it showed some junk characters. that is the contents of floppy.
> so do you suspect anything wrong in copying the file. once i do "dd" what should be the contents of floppy.
> 5. I checked the BIOS boot order options properly. floppy is first.
> 6. rebooted the machine. the rest i have already told.
> 7. same floppy i tried in different machine (windows PC) by changing the boot order as floppy first. but still it does'nt work.
> 
> Meanwhile i will try in other linux machine. do you suspect anything wrong with procedure i followed

Try it without the "mount" - it should work.

-- 
.--------------------------------------------------------.
|       Mind: Embedded Linux and eCos Development        |
|--------------------------------------------------------|
| Gary Thomas              email:  gary.thomas@mind.be   |
| Mind ( http://mind.be )  tel:    +1 (970) 229-1963     |
| gpg: http://www.chez-thomas.org/gary/gpg_key.asc       |
'--------------------------------------------------------'



More information about the Ecos-discuss mailing list