[ECOS] /dev/serx device driver

Gary Thomas gary@mlbassoc.com
Wed Dec 10 11:14:00 GMT 2003


On Wed, 2003-12-10 at 03:59, Ricardo Andrino wrote:
> Hello,
> after several temptations i couldn't see the output of printf (hello.c) 
> function without using Redboot. I don't  know if that can be really made. 

So, why don't you just install RedBoot?  Then your problems will be 
solved.  If you must run via Angel, then you need to make sure that
  CYGSEM_HAL_USE_ROM_MONITOR 
it not set.

> My actual configuration is as follow:
> 
> *AT91EB40A
> *Serial A, port 0
> *COM of Pc to download the programs and connects to Angel Monitor:/dev/ttyS0
> 
> *CYGDAT_IO_SERIAL_TTY_CONSOLE = /dev/tty1 (my actual console)
> *CYGDAT_IO_SERIAL_TTY_TTY1 = enable
> *CYGDAT_IO_SERIAL_TTY_TTY1_DEV = /dev/ttyS0 or /dev/ser0 ?

/dev/ser0

> 
> *CYGPKG_IO_SERIAL_DEVICE = enable
> *CYGPKG_IO_SERIAL_ARM_AT91_SERIAL0 = enable
> *CYGPKG_IO_SERIAL_ARM_AT91_SERIAL0_NAME = /dev/ser0
> 
> *CYGDAT_LIBC_STDIO_DEFAULT_CONSOLE = /dev/ser0 or /dev/tty1?

/dev/tty1

> 
> When i type this command ls -lisa in the /dev directory no /dev/serx appear.
> I don't know if ecos make it or should i./dev/ser0 is the physical driver 
> for port 0 isn't it?

These are not related at all.  The devices on your target board
have nothing to do with the devices which show up on your desktop.

> 
> I think that when the program running on the board finds a printf 
> function must write the strings in the serial device output buffer 
> and then send them to the /dev/ser0 (port 0 for the board?).The Pc 
> must read them in /dev/ttyS0 and finally send them to a terminal, 
> in my case /dev/tty1.is something wrong in all of this? Are all 
> connection describing above correct? Why my program hangs up when 
> runnig but is downloaded correct?
> 
> I do aprreciate any kind of help because i have tried to make it 
> for 2 days without success.

Install RedBoot -> be happy :-)

-- 
Gary Thomas <gary@mlbassoc.com>
MLB Associates


-- 
Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
and search the list archive: http://sources.redhat.com/ml/ecos-discuss



More information about the Ecos-discuss mailing list