[ECOS] Error in run tests

Ricardo Andrino ricardo_andrino@web.de
Wed Dec 3 14:53:00 GMT 2003


Hello, i have found in the documentation and Angel Monitor copy itself from flash into RAM (0x00020000-0x0003FFFF) so my program don't use the same memory area as Angel.So I don't understand why all the programs hang up.
 I want to install Redboot but first i want to run these programs ( RAM start-up)without redboot.

Any idea?

Thanks in advance.

Andrew Lunn <andrew@lunn.ch> schrieb am 02.12.03 17:38:14:
> 
> On Tue, Dec 02, 2003 at 05:13:06PM +0100, Ricardo Andrino wrote:
> > Hello again,
> > I have now chosen the RAM start up but when i try to run the tests the program or the examples these programs hang up.See please the following:
> > ***************************************************************************
> > Run started
> > (gdb) set height 0
> > set height 0
> > (gdb) set debug remote 0
> > set debug remote 0
> > (gdb) set remotebaud 38400
> > set remotebaud 38400
> > (gdb) target rdi /dev/ttyS1
> > target rdi /dev/ttyS1
> > Angel Debug Monitor (serial) 1.04 (Advanced RISC Machines SDT 2.5) for AT91EB40A (1.00)
> > Angel Debug Monitor rebuilt on Feb 03 2002 at 16:09:59
> > Serial Rate:  38400
> > (gdb) load
> > load
> > Loading section .rom_vectors, size 0x40 lma 0xc000
> > Loading section .text, size 0x6dec lma 0xc040
> > Loading section .rodata, size 0x448 lma 0x12e2c
> > Loading section .data, size 0x2bc lma 0x13274
> > Start address 0xc040, load size 30000
> > Transfer rate: 26666 bits/sec, 491 bytes/write.
> > (gdb) break cyg_test_exit
> > break cyg_test_exit
> > Breakpoint 1 at 0xead0: file /opt/ecos/ecos-snapshot-2003-11-25/packages/infra/current/src/tcdiag.cxx, line 267.
> > (gdb) break cyg_assert_fail
> > break cyg_assert_fail
> > Function "cyg_assert_fail" not defined.
> > (gdb) break cyg_test_init
> > break cyg_test_init
> > Breakpoint 2 at 0xe9e0: file /opt/ecos/ecos-snapshot-2003-11-25/packages/infra/current/src/tcdiag.cxx, line 192.
> > (gdb) cont
> > cont
> > Continuing.
> > ****************************************************************************
> > I don't really know why i can not run the test.It's suppose that it is easy isn't it? and that is only the beginnig!!!!!!! Oh God!!!
> > 
> > Any idea?
> 
> First of, do what we have all suggested. Swap to redboot. Thats how
> eCos has been tested and thats the configuration we know it works
> in. Its quite possible the setup you are using now the application is
> using the same memory as Angel.
> 
> > Another question, i have added the Redboot package in the ecos
> > configuration tool but if i clicked in Built Redboot ROM elf image,
> > there are 2 error and the target.ld is not created, When i disable
> > this option there is no problem why? I will need this file to
> > download redboot won't i?
> 
> That is not the correct way to build Redboot. Read the documentation.
> 
>      Andrew


______________________________________________________________________________
WEB.DE FreeMail wird 5 Jahre jung! Feiern Sie mit uns und
nutzen Sie die neuen Funktionen http://f.web.de/features/?mc=021130


-- 
Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
and search the list archive: http://sources.redhat.com/ml/ecos-discuss



More information about the Ecos-discuss mailing list