[ECOS] Re: arm evaluator e7t hangs when executing example progs/tests

Matt Kober mattkober@web.de
Wed Apr 16 22:08:00 GMT 2003


Chris Garry provided me with a redboot image and the twothreads.out file that worked on his 
e7t. i had no luck with it. i even had a chance to try the files on 2 other e7t's but they showed
the same behavior.
i did some debugging of a simple interrupt prog written in c (without eCos) and it seems like 
the external interrupt that i used doesn't get processed correctly. the interrupt pending bit is 
set but the cpu doesn't vector to the isr. i have to check that out more carefully tomorrow.

has anyone had a similar problem before ? i mean it seems to be a general problem with
all e7t's i have tried.

Matt


> Well unless you've got someone to do the testing for you on independent 
> hardware, you haven't got much of a baseline to compare against. Getting 
> the redboot prompt is certainly a start, but redboot does nothing with 
> interrupts of course, so redboot can't verify that.
> 
> Have you tried the eCos HAL test "intr"? Or write your own?
> 
> Jifl
> -- 

______________________________________________________________________________
UNICEF bittet um Spenden fur die Kinder im Irak! Hier online an
UNICEF spenden: https://spenden.web.de/unicef/special/?mc=021101


-- 
Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
and search the list archive: http://sources.redhat.com/ml/ecos-discuss



More information about the Ecos-discuss mailing list