[ECOS] arm evaluator e7t hangs when executing example progs/tests

Chris Garry cgarry@sweeneydesign.co.uk
Sun Apr 13 12:28:00 GMT 2003


> > I enabled assertions and tracing and also disabled compiler optimisation.
> > Just for the fun of it i even tried the bitmap scheduler but without any better results 
> > though.the bin_sem0 test seems to complete correctly and "pass" is displayed but 
> > then the board crashes anyway. the same thing with mutex0, the others don't even 
> > get to display a friendly "pass" before the crash.
> > to me it looks like the problem is occuring in the idle task.
> > i'm kind of desperate, could you please have a look at the attached gdb log file ?
> 
> I've had a look, and (unfortunately) I can't see anything wrong. The 
> threads start, delay and so on. What it seems to be is "simply" that the 
> clock interrupt doesn't happen - I don't think it's anything to do with 
> the idle thread itself as there's not meant to be anything in there. While 
> it might be conceivable the idle thread stack could get overrun, it seems 
> very unlikely given that there's only one interrupt to take.
> 
> The fact you can't ctrl-c it implies the serial interrupt doesn't work 
> either; i.e. *no* interrupts work.
> 
> To debug it I'd suggest setting a breakpoint somewhere like 
> cyg_idle_thread_main, and try and poke the processor state to find out 
> what the status of global interrupts and individual interrupt masks is, as 
> well as what eCos's interrupt structures point to for those interrupts.
> 
> Of course there's always the possibility of a hardware problem...
> 
> You should probably say what version or date of RedBoot you are using.
> 

I ran the mutex tests (mutex0, mutex1, mutex2 and mutex3) on my e7t
using the first the 2.0b1 code and then the latest CVS code and they
all passed fine.

The RedBoot I used was built using the 2.0b1 code.  One point to note
is that my sources have been slightly modified to use 32M of SDRAM
on a daughter board instead of the E7T's 512K of SRAM - but I don't
think this should make any difference.

If nobody has alraedy done this, I will run the tests as described at
http://sources.redhat.com/ecos/testing.html using unmodified 2.0b1
code on my E7T. However I think the 'default' template will have to
be used instead of the 'all' template in order to fit in the 512K of
SRAM.

--
Chris

-- 
Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
and search the list archive: http://sources.redhat.com/ml/ecos-discuss



More information about the Ecos-discuss mailing list