[ECOS] ecos-c

Donnat Eric e.donnat@silicomp.fr
Wed Apr 9 09:23:00 GMT 2003


On Wed, 09 Apr 2003 10:57:54 +0200
"Adolfo Lucha" <Adolfo.Lucha@controlware.de> wrote:

> Hello,
> 
> i am not sure if this the right discussion forum for my question. Sorry if it is not.
> 
> I am developing a system with eCos on a own ppc HW. I am using T32 debugger from http://www.Lauterbach.de company. It will show me my private project files in a rigth manner but the eCos files will not be showed. The problem is that the debugger will not found the files because the path is prefixed with "/ecos-c/...". T32 is a Win32 application and can not expand such text to a drive letter. Therefore I am not able to step through the eCos code.
> 
> I fell that there is a compiler or linker flag to say: do not use the cygwin path ("/ecos-c/"), and use the windows drive letter instead. Is not it? I did not find it :-(
> 
> Or need I any settings in the cygwin environment? Mount flags? ECos configuration settings?
> 
> Any Idea?
> 

IMHO, cygwin is not involved. It's more likely an issue of ecosconfig options. I mean, the Makefile
variant generated is only configurable via a static #define, while it may be controlled via command
line.

> thanks and regards,
> Adolfo
> 
> 
> 
> -- 
> Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
> and search the list archive: http://sources.redhat.com/ml/ecos-discuss
> 
> 


-- 
Eric DONNAT

Silicomp Research Institute
195, rue Lavoisier
ZIRST-BP1
38330 Montbonnot-St-Martin (France)

http://www.ri.silicomp.com

-- 
Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
and search the list archive: http://sources.redhat.com/ml/ecos-discuss



More information about the Ecos-discuss mailing list