[ECOS] How di I fix this problem in ecos?

Greg Holdren greghol@sbcglobal.net
Wed Nov 6 20:54:00 GMT 2002




> On Tue, 2002-11-05 at 17:01, MAX Kuo wrote:
> > hello everyone
> >
> > I use the latest cvs and run a test in ecos.
> > I choose the eb40 template and build the test.
> > but it shows the error below:
> >
> > can anyone tell me how to fix this error??
> >
> >
> > max
> >
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
> >
c/PROGRA~1/REDHAT~1/ecos/packages/language/c/libc/stdio/current/src/input/
>
> -mcpu=arm7tdmi -mno-short-load-words -Wall -Wpointer-arith -Wstrict-protot
ypes
> > -Winline -Wundef -Woverloaded-virtual -g -O2 -ffunction-sections
> > -fdata-sections -fno-rtti -fno-exceptions -fvtable-gc -finit-priority
> > -Wp,-MD,src/input/fgetc.tmp -o src/input/language_c_libc_stdio_fgetc.o
> >
/ecos-c/PROGRA~1/REDHAT~1/ecos/packages/language/c/libc/stdio/current/src/in
pu
> > t/fgetc.cxx
> >
/ecos-c/PROGRA~1/REDHAT~1/ecos/packages/language/c/libc/stdio/current/src/in
pu
> > t/fgetc.cxx:129: `
> >    int getc(CYG_ADDRESS (*)[9999])' defined both normally and as an
alias
> > make[1]: *** [src/input/fgetc.o.d] Error 1
> >
>
> Don't use GCC-3.x
>

I grabbed gcc-3.2 to build i386-elf tools for the PC target and I get the
same error. Drop down to 2.xx.
I have had luck so far with gcc-3.0.2 arm-elf with the EB40. This is what I
use for my ARM targets :)

Greg





-- 
Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
and search the list archive: http://sources.redhat.com/ml/ecos-discuss



More information about the Ecos-discuss mailing list